Difference between revisions of "MiniAudicle/Bugs/PLOrk"

From CSWiki
Jump to: navigation, search
m
m
Line 13: Line 13:
  
 
=== Invalid Tokens ===
 
=== Invalid Tokens ===
* '''severity''': showstopper (this while it doesn't happen all the time can be highly frustrating when it does, affects power users and plork students alike.  is there an easy fix to this?)
+
* '''severity''': showstopper (while this doesn't happen all the time, it can be highly frustrating/baffling when it does, affects power users and plork students alike.  is there an easy fix to this?)
 
* '''reported by''': Dan Trueman (original) and Ge (entered on wiki with additions)
 
* '''reported by''': Dan Trueman (original) and Ge (entered on wiki with additions)
 
* '''description''': in the mA editor, invisible, "junk" characters linger:
 
* '''description''': in the mA editor, invisible, "junk" characters linger:
Line 24: Line 24:
 
** Perry (system config?)
 
** Perry (system config?)
 
** Seth (system config?)
 
** Seth (system config?)
** Ge-1 (see below), mA/ChucK versions: 0.1.3.8b/1.2.1.2-rc3
+
** Ge-1 (see below)
  
 
== testers/users and machine configurations ==
 
== testers/users and machine configurations ==
Line 31: Line 31:
  
 
=== (Ge) ===
 
=== (Ge) ===
* (Ge-1) '''machine/OS''': MacBook Pro / OS 10.4.11
+
* (Ge-1) '''machine/OS''': MacBook Pro / OS 10.4.11 | '''mA:''': 0.1.3.8b | '''ChucK:": 1.2.1.2-rc3
* (Ge-2) '''machine/OS''': PowerBook G4 / OS 10.4.11
 
* (Ge-3) '''machine/OS''': PlanetCCRMA under Fedora 6
 

Revision as of 02:18, 6 January 2008

Here are some potentially "showstopper" or otherwise really undesirable bugs for using the miniAudicle for teaching/performance in PLOrk.

So far many of the really serious ones are related to weird/misleading behaviors in the mA editor, secondarily in preferences, including:

  • syntax highlighting weirdness
  • inconsistency in treating "invalid" tokens (miniAudicle doesn't display them, but they are there). this leads to all kinds of problems from being unable to save current buffers, weird "invalid token" messages when running the code in command line chuck, and I (ge) suspect that this may have something to do with the weird syntax highlighting.
  • indentation (it's important to have smart indentation, but it's too buggy to use currently)
  • in general, the mA seems quite crash prone, especially to new users
  • (preferences?) sometimes the mA starts with 0 DAC channels, a workaround is to open preferences, and select the channel numbers again.
  • on-the-fly visual feedback should be enabled by default.

Specific Bugs

Invalid Tokens

  • severity: showstopper (while this doesn't happen all the time, it can be highly frustrating/baffling when it does, affects power users and plork students alike. is there an easy fix to this?)
  • reported by: Dan Trueman (original) and Ge (entered on wiki with additions)
  • description: in the mA editor, invisible, "junk" characters linger:
    • they cause invalid tokens warnings when run in the command line chuck
    • sometimes, junk characters seem to be introduced from the editor itself (perhaps with accidental pressing of special key characters)
    • possibly causing incorrect syntax highlighting
    • occasional problems either closing or saving a buffer (sometimes, it gets such that you can do neither) - this sometimes happen when copying formatted text (e.g., from web) into the mA
  • verified by:
    • Dan (system config?)
    • Perry (system config?)
    • Seth (system config?)
    • Ge-1 (see below)

testers/users and machine configurations

To aid this bug hunt process, please make an entry for yourself:

(Ge)

  • (Ge-1) machine/OS: MacBook Pro / OS 10.4.11 | mA:: 0.1.3.8b | ChucK:": 1.2.1.2-rc3