Difference between revisions of "Taps/Platform"

From CSWiki
Jump to: navigation, search
m
m
 
(3 intermediate revisions by the same user not shown)
Line 84: Line 84:
 
Flickers at all frame rates, maybe slightly slower for the very slow frame rates
 
Flickers at all frame rates, maybe slightly slower for the very slow frame rates
 
Flickers even after display drivers are updated
 
Flickers even after display drivers are updated
 +
</pre>
 +
* Unresolved.
 +
 +
 +
<pre>
 +
(Run-time)
 +
Ubuntu using jack
 +
Does not run unless Jack is open and set to 48kHz
 +
</pre>
 +
* Unresolved, besides the trivial solution of opening Jack and setting it to 48kHz.
 +
 +
 +
<pre>
 +
(Run-time)
 +
Ubuntu 9.04 (and maybe other versions)
 +
Windowing problems: tearing, messy layering with parts of other windows showing through
 +
Noted when using Compiz for windowing, but not tested without Compiz
 
</pre>
 
</pre>
 
* Unresolved.
 
* Unresolved.
Line 89: Line 106:
  
 
====MAC OS X====
 
====MAC OS X====
 +
 +
<pre>
 +
(Run-time)
 +
Starting taps results in normal Terminal output, but no GUI appears
 +
</pre>
 +
* Try starting taps, going to Preferences and clicking "Set Defaults", and re-starting taps.
 +
  
 
<pre>
 
<pre>
Line 117: Line 141:
 
(Run-time)
 
(Run-time)
 
Green sphere in flippers not visible even when flippers are on
 
Green sphere in flippers not visible even when flippers are on
 +
</pre>
 +
* Unresolved.
 +
 +
 +
<pre>
 +
(Run-time, Vista)
 +
Setting start-level of stochastic template from 1 to max value crashes
 
</pre>
 
</pre>
 
* Unresolved.
 
* Unresolved.

Latest revision as of 19:37, 10 January 2010

While we try to make our software platform-independent, some problems do arise on some platforms. For the benefit of the taps user community, here is a list of specific issues reported by users, along with temporary solutions if available.


Note: It may be extra hard to make taps work on:

  • 64-bit platforms
  • Windows 98 or older
  • ...


Anywhere

(Run-time)
Audio stuttering
High CPU usage, even at low frame rates
Other weird behavior
  • Check that hardware rendering is enabled for graphics on your system.
  • Try installing new drivers for your graphics card.


(Run-time)
Sliders/buttons don't do anything
Text looks blurred
  • Is it a 64-bit platform?
  • If so, can it be compiled in 32-bit mode?
  • There is also a patch for 64-bit machines from Daniel Schmitt. It fixes some things, but other problems may come up later.


LINUX

(Compile-time)
Debian
"Conflicting declaration" errors for pthread
  • The system may have two different pthread libraries.
  • If so, try deleting one or explicitly setting things up to use just one library.


(Run-time)
Debian Lenny
No sound produced even in 32-bit mode
  • It may still work on Debian Etch, possibly related to different library versions in the different distributions.


(Run-time)
Debian
Error including the phrase "Visual with necessary capabilities not found"
  • Try removing some flags (such as GLUT_ALPHA) from the glutInitDisplayMode() function in audicle_gfx.cpp and re-compiling.
  • Information extracted from here.


(Run-time)
Ubuntu using jack
Error includes the phrase "No devices found for compiled audio APIs"
  • Try...
    • Installing jackd ("sudo apt-get install taps jackd")
    • Starting jackd ("jackd -d alsa")
    • Running taps ("taps")
  • Information extracted from here


(Run-time)
Ubuntu
GUI looks fuzzy
  • Unresolved; possibly related to graphics settings.


(Run-time)
Mandriva using jack and i686, but maybe also other set-ups
GUI flickers a lot
Flickers at all frame rates, maybe slightly slower for the very slow frame rates
Flickers even after display drivers are updated
  • Unresolved.


(Run-time)
Ubuntu using jack
Does not run unless Jack is open and set to 48kHz
  • Unresolved, besides the trivial solution of opening Jack and setting it to 48kHz.


(Run-time)
Ubuntu 9.04 (and maybe other versions)
Windowing problems: tearing, messy layering with parts of other windows showing through
Noted when using Compiz for windowing, but not tested without Compiz
  • Unresolved.


MAC OS X

(Run-time)
Starting taps results in normal Terminal output, but no GUI appears
  • Try starting taps, going to Preferences and clicking "Set Defaults", and re-starting taps.


(Run-time)
Occasional flickering with green lines across screen, especially near user interface elements
  • Try replacing your video card... (if not related to OS update)


(Run-time)
Starting Terminal.app actually starts taps executable (or tries to)
Normal Terminal window no longer available
  • Unresolved.


WINDOWS

(Run-time)
Anything weird
  • Re-start and try again.


(Run-time)
Green sphere in flippers not visible even when flippers are on
  • Unresolved.


(Run-time, Vista)
Setting start-level of stochastic template from 1 to max value crashes
  • Unresolved.


Back to Tapestrea